const regex = /\bAmazon\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bAmazon\\b(?!(?:(?!<\\\/?a\\b[^>]*>).)*?<\\\/a>)', 'gm')
const str = `<a>Amazon</a>Amazon
I use Amazon for that.
I use <a href="http://www.amazon.com">Amazon</a> for that.
<a href="http://www.amazon.com">My Amazon Link</a>
It will match the "Amazon" in "My Amazon Link"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}