import re
regex = re.compile(r"\bAmazon\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)", flags=re.MULTILINE)
test_str = ("<a>Amazon</a>Amazon\n"
"I use Amazon for that.\n"
"I use <a href=\"http://www.amazon.com\">Amazon</a> for that.\n"
"<a href=\"http://www.amazon.com\">My Amazon Link</a>\n"
"It will match the \"Amazon\" in \"My Amazon Link\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")