const regex = /(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)(?:r?uary|ch|il|e|y|ust|tember|ober|ember)? +\d{1,2} +\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)(?:r?uary|ch|il|e|y|ust|tember|ober|ember)? +\\d{1,2} +\\d{4}', 'gm')
const str = `Jan 15 2025
January 15 2025
Feb 15 2025
February 15 2025
Mar 15 2025
March 15 2025
Apr 15 2025
April 15 2025
May 15 2025
Jun 15 2025
June 15 2025
Jul 15 2025
July 15 2025
Aug 15 2025
August 15 2025
Sep 15 2025
September 15 2025
Oct 15 2025
October 15 2025
Nov 15 2025
November 15 2025
Dec 15 2025
December 15 2025
Febtember 39 9382`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}