$re = '/(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)(?:r?uary|ch|il|e|y|ust|tember|ober|ember)? +\d{1,2} +\d{4}/m';
$str = 'Jan 15 2025
January 15 2025
Feb 15 2025
February 15 2025
Mar 15 2025
March 15 2025
Apr 15 2025
April 15 2025
May 15 2025
Jun 15 2025
June 15 2025
Jul 15 2025
July 15 2025
Aug 15 2025
August 15 2025
Sep 15 2025
September 15 2025
Oct 15 2025
October 15 2025
Nov 15 2025
November 15 2025
Dec 15 2025
December 15 2025
Febtember 39 9382';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);