re = /([A-Za-z]+)(?:\.([A-Za-z]+))?(?:\.([A-Za-z]+))?\.\d+@[^\s@]+/m
str = 'firstname.1234@email.com
firstname.lastname.1234@email.com
firstname.middlename.lastname.1234@email.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end