import re
regex = re.compile(r"^D7[4-5]{1}............", flags=re.MULTILINE)
test_str = ("D74000000016CCC \n"
"D7400000001813B \n"
"D7400000001991B \n"
"D74000000019E07 \n"
"D74000000019F99 \n"
"D7400000001A4A4 \n"
"D7400000001A53E\n"
"D7400000001A5C2\n"
"D7500000008E44C \n"
"D7500000008F94E \n"
"D750000000901B2 \n"
"D75000000095FB1\n"
"D7500000009B218\n"
"D750000000A36E1\n"
"D750000000AD9AA\n"
"D750000001135DB\n"
"D75000000118DC1\n"
"D75000000119E91\n"
"D75............\n"
"D74............\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")