re = /^D7[4-5]{1}............/m
str = 'D74000000016CCC
D7400000001813B
D7400000001991B
D74000000019E07
D74000000019F99
D7400000001A4A4
D7400000001A53E
D7400000001A5C2
D7500000008E44C
D7500000008F94E
D750000000901B2
D75000000095FB1
D7500000009B218
D750000000A36E1
D750000000AD9AA
D750000001135DB
D75000000118DC1
D75000000119E91
D75............
D74............
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end