package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+`)
var str = `1-3 a: abcde
1-3 b: cdefg
2-9 c: ccccccccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}