$re = '/\w+/m';
$str = '1-3 a: abcde
1-3 b: cdefg
2-9 c: ccccccccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);