import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![AEIOU])[A-Z]$";
final String string = "A\n"
+ "B\n"
+ "C\n"
+ "D\n"
+ "E\n"
+ "F\n"
+ "G\n"
+ "H\n"
+ "I\n"
+ "J\n"
+ "K\n"
+ "L\n"
+ "M\n"
+ "N\n"
+ "O\n"
+ "P\n"
+ "Q\n"
+ "R\n"
+ "S\n"
+ "T\n"
+ "U\n"
+ "V\n"
+ "W\n"
+ "X\n"
+ "Y\n"
+ "Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}