re = /^(?![AEIOU])[A-Z]$/m
str = 'A
B
C
D
E
F
G
H
I
J
K
L
M
N
O
P
Q
R
S
T
U
V
W
X
Y
Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end