using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http://dummy\.projects\.com/activation/(.+)$";
string input = @"http://dummy.projects.com/activation/**ZTlhMDNhOGVkZV8xNTY3Mjk3MjAw**
http://dummy.projects.com/activation/**ZTlhMDNhOGVkZV8xNTY3Mjk3MjAw**";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}