import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http://dummy\\.projects\\.com/activation/(.+)$";
final String string = "http://dummy.projects.com/activation/**ZTlhMDNhOGVkZV8xNTY3Mjk3MjAw**\n"
+ "http://dummy.projects.com/activation/**ZTlhMDNhOGVkZV8xNTY3Mjk3MjAw**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}