using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=&categories=).*?([^;&]+)";
string input = @"text&variable=tekst2&categories=metal;wood&author:elvis;arnold";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}