$re = '/(?<=&categories=).*?([^;&]+)/';
$str = 'text&variable=tekst2&categories=metal;wood&author:elvis;arnold';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);