$re = '/^([0-9]*\s[\*\+\/\%\-]\s[0-9]*)$/m';
$str = '1-AAA-123
AAA-000
234 + 32468533830
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);