re = /^([0-9]*\s[\*\+\/\%\-]\s[0-9]*)$/m
str = '1-AAA-123
AAA-000
234 + 32468533830
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end