using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"v(?!\d{2})";
string input = @"123v1
123v01
123v001
123vWORD_HERE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}