$re = '/v(?!\d{2})/m';
$str = '123v1
123v01
123v001
123vWORD_HERE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);