#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ": *\K\w+"
Local $sString = "savedPosition: comp;" & @CRLF & _
"" & @CRLF & _
"CURLSCHET.NREC ('qwertyuiop'): noprotect;" & @CRLF & _
"TEXT : noprotect; text here and: yeah (word) some more: noway "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")