using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @": *\K\w+";
string input = @"savedPosition: comp;
CURLSCHET.NREC ('qwertyuiop'): noprotect;
TEXT : noprotect; text here and: yeah (word) some more: noway ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}