$re = '/^(?:(?:0[1-9]|1\d|2[0-8])([\/-])(?:02)\1(?:\d+)|(?:0[1-9]|1\d|2\d)([\/-])(?:02)\2(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))|(?:0[1-9]|1\d|2\d|30)([\/-])(?:0[469]|11)\3(?:\d+)|(?:0[1-9]|1\d|2\d|3[01])([\/-])(?:0[13578]|1[02])\4(?:\d+)|(?:02)([\/-])(?:0[1-9]|1\d|2[0-8])\5(?:\d+)|(?:02)([\/-])(?:0[1-9]|1\d|2\d)\6(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))|(?:0[469]|11)([\/-])(?:0[1-9]|1\d|2\d|30)\7(?:\d+)|(?:0[13578]|1[02])([\/-])(?:0[1-9]|1\d|2\d|3[01])\8(?:\d+)|(?:\d+)([\/-])(?:0[1-9]|1\d|2[0-8])\9(?:02)|(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))([\/-])(?:0[1-9]|1\d|2\d)\10(?:02)|(?:\d+)([\/-])(?:0[1-9]|1\d|2\d|30)\11(?:0[469]|11)|(?:\d+)([\/-])(?:0[1-9]|1\d|2\d|3[01])\12(?:0[13578]|1[02])|(?:\d+)([\/-])(?:02)\13(?:0[1-9]|1\d|2[0-8])|(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))([\/-])(?:02)\14(?:0[1-9]|1\d|2\d)|(?:\d+)([\/-])\15(?:0[469]|11)(?:0[1-9]|1\d|2\d|30)|(?:\d+)([\/-])(?:0[13578]|1[02])\16(?:0[1-9]|1\d|2\d|3[01]))$/m';
$str = '30/11/2017
30-11-2017
2017-05-31
30-/11-/2017
30-11/2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);