$re = '/(1[8-9]|[2-3][0-9]|40)/m';
$str = '17
18
19
20
21
31
36
39
40
41';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);