import re
regex = re.compile(r"(1[8-9]|[2-3][0-9]|40)", flags=re.MULTILINE)
test_str = ("17\n"
"18\n"
"19\n"
"20\n"
"21\n"
"31\n"
"36\n"
"39\n"
"40\n"
"41")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")