package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d+(?:\.\d+)*\.?|[^.])+`)
var str = `10.1 This is a sentence. Another sentence.
10.1. This is a sentence. Another sentence.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}