$re = '/(?:\d+(?:\.\d+)*\.?|[^.])+/m';
$str = '10.1 This is a sentence. Another sentence.
10.1. This is a sentence. Another sentence.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);