#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z0-9]{4})"
Local $sString = " ; Message Number" & @CRLF & _
" ; | Time Offset (ms)" & @CRLF & _
" ; | | Type" & @CRLF & _
" ; | | | ID (hex)" & @CRLF & _
" ; | | | | Data Length" & @CRLF & _
" ; | | | | | Data Bytes (hex) ..." & @CRLF & _
" ; | | | | | |" & @CRLF & _
" ;---+-- ----+---- --+-- ----+--- + -+ -- -- -- -- -- -- --" & @CRLF & _
" 1) 2.0 Rx 0400 8 01 5A 01 57 01 D2 A6 02 " & @CRLF & _
" 2) 8.6 Rx 0500 8 02 C1 02 C9 02 BE 02 C2 " & @CRLF & _
" 3) 36.2 Rx 0401 8 01 58 01 59 01 01 01 01 " & @CRLF & _
" 4) 41.7 Rx 01C4 8 27 9C 64 8C 00 03 E8 08 " & @CRLF & _
" 5) 43.1 Rx 0501 8 02 C0 02 C1 02 C6 02 C0 " & @CRLF & _
" 6) 62.7 Rx 01C2 8 27 9C 60 90 00 0F 04 08 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")