package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{0,2}(给我|能不能|帮我|请)?(简单)?(介绍|讲讲|说说)(一下|介绍)?#(的情况)?(好不好|可以吗|可以么|吧|阿|啊|呢|哦|哟|呀|呗)?$`)
var str = `介绍一下#
给我说说#
给我介绍一下#吧
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}