import re
regex = re.compile(r"^.{0,2}(给我|能不能|帮我|请)?(简单)?(介绍|讲讲|说说)(一下|介绍)?#(的情况)?(好不好|可以吗|可以么|吧|阿|啊|呢|哦|哟|呀|呗)?$", flags=re.MULTILINE)
test_str = ("介绍一下#\n"
"给我说说#\n"
"给我介绍一下#吧\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")