$re = '/^.+\|(.+\|{1}.+)\|.+$/m';
$str = 'DOWN | Origin - test-pd-2 | Pool - test-pd | TCP timeout occurred';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);