re = /^.+\|(.+\|{1}.+)\|.+$/m
str = 'DOWN | Origin - test-pd-2 | Pool - test-pd | TCP timeout occurred'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end