using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[[:alnum:]]{13}.cloudfront.net$";
string input = @"d8ou8y123d5vy.cloudfront.net";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}