$re = '/^[[:alnum:]]{13}.cloudfront.net$/';
$str = 'd8ou8y123d5vy.cloudfront.net';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);