$re = '/[а-яё]{5}$/';
$str = 'миловидная и отменная графика';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);