$re = '/^\h*price\h*\|\h*\K.*\S/m';
$str = 'hello | Hello there
price | Lets talk about our support.
how are you ?| Im fine ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);