import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]+src=\"?([^\"\\s]+)\"?\\s*";
final String string = "<img alt=\"SOME ALT\" src=\"http://i.imgur.com/UWWQ0Wr.jpg\" title=\"SOME TITLE\">\n"
+ "<img src=\"http://i.imgur.com/1B0mUM2.jpg\" alt=\"SOME ALT\" title=\"SOME TITLE\" />\n"
+ "<img src=\"http://i.imgur.com/UWWQ0Wr.jpg\" alt=\"SOME ALT\" title=\"SOME TITLE\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}