package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<title>\w+), yes \k<title>`)
var str = `"Sir, yes Sir" in "Do you copy? Sir, yes Sir!"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}