$re = '/(?<title>\w+), yes \k<title>/';
$str = '"Sir, yes Sir" in "Do you copy? Sir, yes Sir!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);