$re = '/<td[^>]+>([^<]+)<\/td>/i';
$str = '<td colspan="2" style="font-weight:bold;">HELLO TOTO</td>
<td>Function :</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);