// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<td[^>]+>([^<]+)<\/td>").unwrap();
let string = "<td colspan=\"2\" style=\"font-weight:bold;\">HELLO TOTO</td>
<td>Function :</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}