import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rdstation(?!.*(email|inbound))";
final String string = "utmcsr=rdstation|utmccn=curso-intro-coaching|utmcmd=inbound|utmctr=link3\n"
+ "utmcsr=rdstation|utmccn=agenda-psc|utmcmd=email\n"
+ "utmcsr=rdstation|utmccn=pnl-porto-alegre";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}