$re = '/\b(\w+).*\1\b/';
$str = 'hello here is a really long sequence of words hello stuff.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);