re = /\b(\w+).*\1\b/
str = 'hello here is a really long sequence of words hello stuff.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end