# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a([^>]+?)href\s*=\s*(\"|'|\s?)(.+?)\2(?=\s{1}|>)"
test_str = ("<a href=/pesho></a>\n"
"<a href='Ilia'></a>\n"
"<a class=\"bull\" href=\"http://super-href/dot.com\"></a>\n"
"<a href=/softuni.bg class=\"danger'></a>\n\n"
"<!DOCTYPE html>\n"
"<html>\n"
"<head>\n"
" <title>Hyperlinks</title>\n"
" <link href=\"theme.css\" rel=\"stylesheet\" />\n"
"</head>\n"
"<body>\n"
"<ul><li><a href=\"/\" id=\"home\">Home</a></li><li><a\n"
" class=\"selected\" href=/courses>Courses</a>\n"
"</li><li><a href = \n"
"'/forum' >Forum</a></li><li><a class=\"href\"\n"
"onclick=\"go()\" href= \"#\">Forum</a></li>\n"
"<li><a id=\"js\" href =\n"
"\"javascript:alert('hi yo')\" class=\"new\">click</a></li>\n"
"<li><a id='nakov' href =\n"
"http://www.nakov.com class='new'>nak</a></li></ul>\n"
"<a href=\"#empty\"></a>\n"
"<a id=\"href\">href='fake'<img src='http://abv.bg/i.gif' \n"
"alt='abv'/></a><a href=\"#\"><a href='hello'></a>\n"
"<!-- This code is commented:\n"
" <a href=\"#commented\">commentex hyperlink</a> -->\n"
"</body>\n"
"END")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.