package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(a{0,3}b{0,3}){1,3}$`)
var str = `abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}