$re = '/^(a{0,3}b{0,3}){1,3}$/';
$str = 'abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);