const regex = /(\b\S*\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\S*\\b)', 'g')
const str = `Hi #FirstName, Your Current A/C Request is #Custom1, We Customer #Custom2 On Your Happy Birthday HappyXXXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}