re = /(\b\S*\b)/
str = 'Hi #FirstName, Your Current A/C Request is #Custom1, We Customer #Custom2 On Your Happy Birthday HappyXXXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end