const regex = /^([0-9A-Fa-f]{8}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{12})$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9A-Fa-f]{8}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{12})$', 'gim')
const str = `f27a5b7f-0b7c-4e79-aff5-bdb0d34f3a9f
f27a5b7f0b7c4e79aff5bdb0d34f3a9f`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);