$re = '/^([0-9A-Fa-f]{8}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{4}[-]?[0-9A-Fa-f]{12})$/im';
$str = 'f27a5b7f-0b7c-4e79-aff5-bdb0d34f3a9f
f27a5b7f0b7c4e79aff5bdb0d34f3a9f';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;